Currently Medocity is experiencing system latency within platform
Incident Report for Medocity
Resolved
This incident has been resolved.
Posted Mar 06, 2023 - 14:51 EST
Investigating
We are currently investigating this issue.
Posted Mar 06, 2023 - 14:43 EST